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This document outlines the “central update” method that can be used by the Alliance for
identifying and marking bibliographic records in bound-with relationships. In this method of
marking bound-withs, markers are initially added by the Network Zone Manager in batch
processes. Local institutions add the markers as bound-with relationships are created in their
Alma IZs. Removal of markers is done on a regularly-scheduled basis by the Network Zone
Manager, based on record lists sent in by institutions.

Context and merge rule changes:
In order to make bound-with relationships between host and constituent bibliographic records
visible in the Network Zone, the MARC 979 tag has been defined as a bound-with record
marker. The marker will enable the NZ Manager to filter bound-with records without inventory
out of sets earmarked for deletion during cleanup and maintenance processes in the NZ.
The 979 field is inherently a local field in Alma. In this specific application, the field is added as
a “non-localized” local field. That is, it is added as a normal MARC field and appears without
the $9LOCAL value or the “house” icon next to the field in Alma. This makes the marker visible
to the NZ and all IZs. As such, staff at member institutions will see markers in their bound-with
titles as well as the bound-with titles of other Alliance institutions.
In order to protect the marker from daily update loads in the NZ, the “OCA Bib Overlay (keep
035s)” merge rule has been updated. The line “replace MARC.”9”XX” has been replaced with
two lines:
remove MARC.”9”XX excluding “979”
add MARC.”9”XX
The first line removes all 9XX fields except the 979 in the existing NZ record. The second line
then adds the incoming record’s 9XX fields to the existing record.

Identifying existing bound-withs in your IZ
Based on full instructions from Bob Thomas in 2015, take the following steps to identify your
institution’s bound-with records:
Step 1: Identify potential bound-with host records:
■ Option 1: Create an All Titles set where All titles (Other System Number contains
keywords 99*) and save the resulting set. This will identify records which might have an

MMS ID in the 774$w (bound-with linking field), but it will also include records that are
not bound-with host records. You will need to complete step 3 below.
■ Option 2: If you have used a standard title/text in your host bibliographic records create
an All Titles set where All titles (Keywords contains phrase [“your standard text”]). As
long as this text is specific, you should only have bound-with host records in your set,
and you may skip step 3 below.
■ Option 3: If you have set up an Alma indication rule to identify records with 774$w
subfields, you can create your bound-with host set by running this indication rule
against your entire Alma IZ repository. This will return a set that may contain
non-boundwith records with 774$w data. To remove these, export your set to Excel
and remove the records with holdings attached. The remaining records should all be
bound-with host records. You can skip step 3 below.
Step 2: Export the host records:
■ Run the "Export Bibliographic Records" job against the set you created in step 1, using
Physical format = Binary and Output format = MARC21 Bibliographic.
■ When the job has completed, go to Monitor Jobs -> History tab, and on the line for your
export job, select Actions -> Report.
■ The report will have a hyperlink with a filename that looks like
“BIBLIOGRAPHIC_8987926080001453_1.mrc”. Click on the file name link.
■ On the next screen select Actions -> Download and save the file of bib records on your
computer.
Step 3: Isolate records with bound-with links:
■ 3a: Harvest the 774$w fields:
○ Open MarcEdit and select Tools (along the top row) -> Select MARC Records ->
Extract Selected Records.
○ Change Display Field to 774$w, click on the folder for the Source MARC File and
select the file downloaded in step 2, and click the Import File button.
■ 3b: Isolate the bound-with data:
○ Next, click on the Display Field (774$w) column heading to sort by that column.
○ Check the Retain Checked Items box, click the top line with a value in 774$w
(not the ones that start with (CKB)), hold down CTRL+Shift key and click the last
line with a value in 774$w.
○ If clicking on the line doesn’t check the appropriate boxes, click on one of the
boxes (while the lines are still highlighted), and all the lines should be checked.
○ Check to make sure all lines with a value in 774$w (other than CKB) are now
checked.
■ 3c: Export the Bound-with records in .mrc format:
○ Click the Export Selected button and tell MarcEdit where to put the file of these
bound-with records.

○ Go to MARC Tools (the big icon – not the top row) and choose MarcMaker.
○ Select the file you just created as the input file (it will have a .mrk extension),
select the output file and allow MarcEdit to fill in the output file name, and click
on the Execute button. This converts the records back into MARC binary format.
Step 4: Export 774$w of bound-with records:
■ In MarcEdit, select Tools (on the top row) -> Export -> Export Tab Delimited Records.
○ For the top file name box, click on the folder and select the .mrc file you created
in step 2 (or 3, if you had to use that step).
○ Then click on the folder next to the second file name box and provide a file name
for the .txt file that will be created as part of this process.
○ Choose Tab for the Select Field Delimiter and semicolon for the In field
delimiter fields and click on the Next button.
○ Enter 774 (without quotes) in the Field box and w in the Subfield box, then click
the Add Field link.
○ (Optional): If you want to use this set to add local markers to your host bibs as
well as the constituent bibs, enter 001 (without quotes) in the Field box, leave
the Position box blank, then click the Add Field link.
○ Click the Export button.
Step 5 (Excel version): Formatting the MMS IDs and removing duplicates for Alma set creation:
■ Open Excel and go to File -> Open. Browse to the .txt file from the previous step. Click
Open. This opens the Text Import Wizard.
■ In Step 1 of the wizard, choose the delimited option. Click Next.
■ In Step 2 of the wizard, check the boxes for Tab and Semicolon. Enter “ (double quote)
in the Text qualifier field. Click Next.
■ In Step 3 of the Text Import Wizard, change the Column data format selection from
General to Text (this prevents Excel from displaying pure number values like MMS IDs in
scientific notation) for all columns. Click Finish.
■ The spreadsheet should contain two columns - one with the 774$w numbers, and one
with the 001 data (if you chose to export those fields in the last step). Your next task is
to get all of the numbers in one column. To start:
○ Select all of the values in the “001” column. Copy/cut these cells with CTRL + X.
Scroll to the bottom of the sheet and paste them onto the end of the first
column with CTRL + V. Delete the “001” column header at the top of the sheet.
■ Now you’ll need to split up all of the 774$w data into separate cells. This is a LOT easier
if you can find the longest entry in column A and move it to the top of your spreadsheet.
To find the longest entry and get it to the top of the sheet:
○ Select Column B and choose the Number format for the column. In the first cell,
enter “Length” as the column name. In the second cell of the column, enter the
formula: =LEN(A2). The cell should give a numeric result. Now select that cell

again and double-click the fill handle that appears in its bottom right corner.
This will copy the formula to all of the cells in the column.
○ Select all of the data in the sheet (CTRL + A). Click Sort and Filter > Custom sort.
Check the My data has headers checkbox.  Choose Length as your “Sort by”
column. Select Largest to smallest as your “Order”. Save the spreadsheet.
■ To split the cells, Select Column A and then click Data > Text to columns.
○ On the first page, select Delimited. On the next page, select Semicolon as the
delimiter. On the final page, make sure that all columns are formatted as Text.
(This may take a while if you have many entries on a single line - but since your
longest line is at the top, you won’t have to scroll down to find it!) Click Finish.
■ For really long rows of MMS IDs: select all of the cells in the row(s) and copy with CTRL +
C. Then scroll to the bottom of the sheet and select the first empty cell in Column A.
Right click and in the paste options that appear, select Transpose. This will paste the
row(s) of MMS IDs onto the end of the column. Delete the copied row from the top of
your spreadsheet, and repeat for any other long rows.
■ For shorter rows of MMS IDs, you can use cut (CTRL + X) and paste (CTRL + V) to “move”
columns of MMS IDs from their current columns to the end of column A.
■ Once all of the IDs are in Column A, replace the column heading “774$w” with “MMS
ID” (without the quotes).
■ Select the entire spreadsheet (CTRL+A) and use Data -> Sort to sort the MMS IDs.
■ Use Data -> Remove Duplicates to retain only unique MMS IDs.
■ Save the file in Excel 97-2003 (.xls) format.
Step 5 (OpenRefine version): Formatting the MMS IDs and removing duplicates for Alma set
creation:
■ Start OpenRefine and click Create Project. Click Choose Files and browse to the .txt file
from the previous step. Click Open. Click Next.
■ On the “Configure Parsing Options” page, you should have Tabs selected as the Column
separators, “Parse next 1 line as column headers” checked, and the option for
“Quotation marks are used…” checked. If desired, edit the project name at the top of
the page and click Create project.
■ Your list of MMS IDs will appear, with all of the 774$w and 001 values from each record
on a single line. We want to get all of those values into one column. To do this:
○ Click the down arrow next to the “774$w” column heading. Select Edit Cells >
Split multi-valued cells.
○ In the Separator box, enter a semicolon. Click OK. Your spreadsheet will now
display one column of MMS IDs if you only exported 774$w data. It will show
two columns of IDs if you also exported 001 data.
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○ Fill the empty cells in the 001 column by clicking the down arrow next to the
“001” column heading. Select Edit cells > Transform option. In the Expression
box, paste the following: if(value==null,"Empty",value) . Click OK.
○ To get the 001s added to the first column, click the down arrow next to the
“001” column heading. Select Edit column > Add column based on this column
option.
○ Name the new column “MMS ID”. In the Expression box, paste the following:
cells["774$w"].value + ";" + cells["001"].value . Click OK.
○ Click the down arrow next to the “MMS ID” column heading. Select Edit Cells >
Split multi-valued cells. In the Separator box, enter a semicolon. Click OK. THe
MMS ID column now contains all of the MMS IDs in separate rows.
Using the down arrows, Edit column > Remove this column for both the “774$w” and
“001” columns. This leaves just your “MMS ID” column.
Click the down arrow next to the “MMS ID” column heading. Select Sort. Select the
text and a-z options. Click OK. Now click Sort in the header bar, and select Reorder
rows permanently.
Click the down arrow next to the “MMS ID” column heading. Select Edit cells > Blank
down. This removes duplicate values from the column.
To remove the now-empty rows, click the down arrow next to the “MMS ID” column
heading. Select Facet > Customized facets > Facet by blank. In the left-hand pane, click
on True. Click the down arrow next to the “All” heading and select Edit rows > Remove
all matching rows. In the facet pane, click Remove All to remove the facet.
Click the Last >> button in the upper right to go to the last page of results. Scroll to the
bottom and click the Star for the cell that contains the word “Empty”. Click the down
arrow next to the “All” heading and select Facet > Facet by star. Click True in the facet
pane, then click the down arrow next to the “All” heading and select Edit rows >
Remove all matching rows. In the facet pane, click Remove All to remove the facet.
Finally, click Export in the upper right hand corner. Select the Excel (.xls) option.
Specify a file name and location for the MMS ID list, and then click Save.

Step 6: Create an Alma set of your bound-with records:
■ In Alma, go to Manage Sets and click on Add Set and click the Itemized option. Name
the set and set the content type = All Titles.
■ Browse for your .xls file of MMS IDs created in Step 5 and click the Save button.
■ A set creation job will process the file and add the records to your set. You’ll be notified
by email when the job finishes.
Step 7: Export and drop off your final list of bound-with records:
■ Run the "Export Bibliographic Records" job against the set you created in step 7, using
Physical format = Binary and Output format = MARC21 Bibliographic.

■ When the job has completed, go to Monitor Jobs -> History tab, and on the line for your
export job, select Actions -> Report.
■ The report will have a hyperlink with a file name that looks like
“BIBLIOGRAPHIC_8987926080001453_1.mrc”. Click on the file name link.
■ On the next screen select Actions -> Download and save the file of bib records on your
computer.
■ Rename the file with the following naming convention:
INST_YYYYMMDD_boundwiths.mrc, where INST is your institution’s Alma/Primo
symbol.
■ Drop the file off in this folder on Google Drive. (If you have access problems using the
embedded link, try copying and pasting the link address to your browser’s URL bar.) The
NZ Manager will pick up the files and run a batch process in the NZ to add the
bound-with marker in the MARC 979 field.

Adding the marker to new bound-with bibs:
In order to protect new bound-with records between “refresh” processes, records involved in
any new bound-with relationships in Alma will have to be marked. As of this writing (4/20/18),
a bug in Alma prevents IZ-level jobs using a norm rule to add the marker to NZ records. This
problem has been reported to Ex Libris in Alliance SalesForce case number 00543362. Due to
this problem, markers added from an Alma IZ must be added record-by-record in the Metadata
Editor. In cases where this is not feasible, batches of records may be sent to the Network Zone
Manager for marking.

Adding the marker to a single record
To add the marker to bound-with records one at a time:
1. Open the desired record in the Metadata Editor, and check for an existing 979
“Boundwith record” marker.
2. If no marker is present, use File -> Add Field (F8) to add a 979 field.
a. Code $a as “NZ Boundwith record.”.
Example: 979 _ _ $$a NZ Boundwith record.
b. Note that the marker is not added as an Alma “local” field, which would prevent
it from being seen in the NZ. Instead, add the field as a standard MARC field.
This makes it visible to other institutions and to the Network Zone.
3. If a 979 bound-with marker is already present, no action is needed.
4. Check to ensure that the 979 shows as a standard field without an icon next to it in the
metadata editor.
5. Save and release the record.

Adding the marker to a batch of records
If adding the markers using the Metadata Editor is not feasible for your local workflow, you
have the option of creating an itemized set of your boundwith records, and then following Step
7 of the process above to send them to the Network Zone Manager, who will mark the records
in the NZ.

Removing the bound-with marker:
The other half of keeping the markers accurate is removing them when institutions no longer
have bound-with inventory related to the record in question. This removal will be done by the
NZ Manager via central batch processing on a regular basis.

Regular “refresh” of bound-with markers
This process requires institutions to create an Alma set of their bound-with records and send
them to the Network Zone Manager in .mrc (MARC binary) format.
1. Using the procedure outlined above, create an Alma set of your bound-with
bibliographic records and drop off the records in this Google Drive folder.
a. Be sure to use the file naming convention “INST_YYYYMMDD_boundwiths.mrc”,
where INST is your institution’s Alma/Primo symbol.
2. The NZ Manager will remove all existing boundwith markers from NZ bibs.
3. The NZ Manager will harvest the NZ MMS IDs from the submitted files and add the
bound-with markers to the appropriate NZ records in a batch process.
a. Note that any IZ-only bibs included in your institution’s file will not be marked,
since they are not linked to the NZ and therefore do not need protection.

