CSV (Access or MARCXML) Cleanup & Migration Guidelines

Produced by the Archival Collection Management Working Group of the Content Creation & Dissemination Team
  Sarah Shipley, Seattle Municipal Archives (chair)
  Conor Casey, University of Washington
  Amber d’Ambrosio, Willamette University
  Nathan Georgitis, University of Oregon (author of this document)
  Jodi Allison-Bunnell, Alliance (ex officio)

Version 1.2, September 2017

**Introduction**

**Goals**

**Migration Roles and Responsibilities**
  Accessions CSV to ArchivesSpace
  MARC XML to ArchivesSpace

**Migration Process**

**Reviewing Data in Access**

**Determine the Destination of Data**

**Plan the Data Migration Path**

**Consider Workflow Implications and Import Limitations**

**Map Data and Scope Data Cleanup**
  Mapping Accessions Data
  Mapping Collections and Item Data

**Backup Data in Access**

**Cleanup Data**
  Notes on Editing Data in Excel
  Spellcheck Data
  Controlled Vocabularies and Variant Data
  Formatting Dates
  Supplying Normal Dates
Supplying Standard Notes
Finalizing Data for Import

Backup Data

Import Data to ArchivesSpace
Import Process

Introduction

Migration of collections data to ArchivesSpace (AS) from Microsoft Access provides an opportunity--and, in many cases, the necessity--to review and edit data to ensure complete and accurate migration. This document provides an overview of goals, roles and responsibilities, and methods of preparing and migrating collections data from Access to ArchivesSpace.

Goals

The goals of preparing and migrating collections data are:

- To ensure complete and accurate data migration
- To ensure data functions well in ArchivesSpace and in institutional workflows
- To take the opportunity to resolve any outstanding issues with data
- To facilitate publication of finding aids that comply with Describing Archives: A Content Standard (2nd Edition) and the Alliance’s EAD Best Practices.

Migration Roles and Responsibilities

A&M Collections Service participants will be responsible for preparing and migrating collections data in Access, with some assistance provided as needed by Alliance staff, the working group, and/or LibraryHost.

Accessions CSV to ArchivesSpace
The following specifically addresses the migration Accessions CSV to ArchivesSpace in FY18, identifying each party’s role in data migration. These specifics may change under other circumstances.

Institutions. Institutions must:

- Communicate clearly and completely to the Program Manager (PM) the nature of the data to be imported (what formats, how many records, etc.), and any anticipated support needs.
- Ensure that data are ready to import. Follow the Alliance’s CSV data migration preparation guidelines (this document) to clean up data.
- Review the ArchivesSpace mapping and template documentation in order to understand how data will be transformed by the AS import process.
  - If needed, contact the PM (who may in turn refer the Institution to LibraryHost) for support with understanding the mapping of the Institution’s data.
- Import small batches (1-10 records) of data into AS using the Alliance’s instructions for migrating Accessions CSV.
• Review the imported data in the AS instance, compare with the original, make note of any errors and/or corrections needed, and either:
  ○ Make corrections in the original records and re-import, or
  ○ Communicate with the PM (who may in turn refer the question to LibraryHost) for support with interpreting reports and adjusting mapping.
• Repeat the import and review process as needed.
• Tell the PM when they have completed the import process.
• Retain copies of the original formatted data for 6 months.

LibraryHost. LibraryHost must:
• Create an AS instance for the institution and transmit credentials to the PM.
• Respond to Institution questions about mapping, import errors, and other processes related to CSV import.

Alliance. Alliance must:
• Assist the Institution with making any needed cleanup during the migration and review process.
• Facilitate support requests to LH, ensuring prompt responses and adherence to the Service Agreement.
• In order to perform adequate support, the Alliance may access the Institution’s instance from time to time. The Alliance will not make changes to the Institution’s data without first informing the Institution.

MARC XML to ArchivesSpace
The following specifically addresses the migration of MARC XML to ArchivesSpace in FY18, identifying each party’s role in Data Migration.

Institutions. Institutions must:
• Communicate clearly and completely to PM the nature of the data to be imported (what formats, how many records, etc), and any anticipated support needs.
• Ensure that data are ready to import. Follow the Alliance’s MARC XML data migration preparation guidelines to clean up data.
• Review the ArchivesSpace mapping and template documentation in order to understand how data will be transformed by the AS import process.
  ○ If needed, contact the PM (who may in turn refer the Institution to LibraryHost) for support with understanding the mapping of the Institution’s data.
• Import small batches (1-10 records) of data into AS using the Alliance’s instructions for migrating MARC XML.
• Review the imported data in the AS instance, compare with the original, make note of any errors and/or corrections needed, and either:
  ○ Make corrections in the original data and re-import, or
  ○ Communicate with the PM (who may in turn refer the question to LibraryHost) for support with interpreting reports and adjusting mapping.
• Repeat the import and review process as needed.
• Tell the PM when they have completed the import process.
• Retain copies of the original formatted data for 6 months.

LibraryHost. LibraryHost must:
• Create an AS instance for the Institution and transmit credentials to the PM.
- Respond to Institution questions about mapping, import errors, and other processes related to CSV import.

Alliance. Alliance must:
- Assist the Institution with making any needed cleanup during the migration and review process.
- Facilitate support requests to LH, ensuring prompt responses and adherence to the Service Agreement.
- In order to perform adequate support, the Alliance may access the Institution’s instance from time to time. The Alliance will not make changes to the Institution’s data without first informing the Institution.
Migration Process

Below is an overview of the process of preparing and migrating collections data in Access to AS.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Review data in the Access database to determine the type of data that you will be migrating: accessions, resource records, items, digital objects, subjects, agents, etc.</td>
</tr>
</tbody>
</table>
| 2    | Determine the destination of data in ArchivesSpace  
|      | AS Accessions  
|      | AS Resources  
|      | AS Subjects  
|      | AS Agents  
|      | AS Controlled Vocabularies |
| 3    | Review data import options for ArchivesSpace  
|      | AS Accessions CSV Template for accessions  
|      | AS Digital Object CSV Template for digital objects  
|      | EAD .xml import for collection or item level data  
|      | MARC .xml import for collection level data |
| 4    | Consider workflow implications and import limitations and identify data migration path |
| 5    | Map data in AS Accessions, AS Resources, or AS Digital Objects and scope data cleanup |
| 6    | Create a backup copy of the Access database |
| 7    | Cleanup data in Access, Excel, or EAD .xml depending on your data migration path |
| 8    | Import cleaned data to ArchivesSpace |

Reviewing Data in Access

You can review collections data in Access or export data to Excel to review. Access is a relational database management system and may include multiple tables of data that are related through the use of keys, or unique identifiers for each record.

To export data to Excel:
- browse tables and identify table for export  
- select the table to open in Datasheet view  
- select External Data tab and choose export to Excel  
- in export window, edit file name as necessary  
- in export window, select export option “Export data with formatting and layout”  
- in export window, select export option “Open the destination file”  
- in Excel, review data for missing or incorrect values  
  - In case of missing or incorrect values, see Access help menu item “Troubleshoot missing and incorrect values”
Once the destination of the data is determined, plan the migration path from Access to ArchivesSpace. Determine the Destination of Data

Based on your review of the data, determine its destination in ArchivesSpace.

- If the data describes **accessions**, the destination will be AS Accessions.
- If the data describes **collections**, the destination will be AS Accessions or AS Resources, depending on local practice and the nature of the data. Data appropriate for a MARC record or a more detailed EAD finding aid, meaning data that is useful for discovery, access, and use of collections by researchers, should be destined for AS Resources. See the [Alliance’s EAD Best Practices](https://alliancearchives.org/guidelines/eadbestpractices) for a table of required and recommended collection-level metadata.
- If the data describes **items** within accessions or collections, the destination will be AS Resources, or possibly AS Digital Objects if the data describes digital items that are available online.
- If the data describes **subjects or names**, the final destination will be AS Subjects or AS Agents, but this data may be imported in association with accessions, resources, items, or digital objects, with some limitations.
- If the data describes **other facets**, such as extent type, container type, name source, etc. the final destination will be AS Controlled Value Lists which may be created in AS through data entry or, for some lists, populated through import of accession, resource, or digital object records containing that data.

Plan the Data Migration Path

Once you determine the destination of the data, plan the data migration path from Access to ArchivesSpace.
Your data migration path will begin in Access and proceed through Excel into one of the AS import options:

- AS Accessions CSV Template and CSV Map
- AS Resources EAD .xml Import / Export Map
- AS Resources MARC .xml Import / Export Map
- AS Digital Object CSV Template, and CSV Map

The tools are linked here: archivesspace.org/application/data-import-and-export-maps
And available on GitHub: https://github.com/archivesspace/archivesspace

For accessions data, the data migration path will be as follows:
- Access>>Excel>>AS Accessions CSV Template>>AS Accessions

For collection level data, the data migration path will be one of the following:
- Access>>Excel>>AS Accessions CSV Template>>AS Accessions
- Access>>Excel>>AS Accessions CSV Template>>AS Accessions>>spawn to AS Resources
- In Access or Excel>>mailmerge to EAD .xml>>AS Resources

For item level data, the data migration path will be as follows:
- In Access or Excel>>mailmerge to EAD .xml shell>>AS Resources>>merge to Resource record

For controlled value list data, the data migration path will be as follows:
- In Access or Excel>>data entry to AS Controlled Value Lists

For digital object data, the data migration path will be as follows:
- Access>>Excel>>AS Digital Object CSV Template>>AS Digital Objects

**Consider Workflow Implications and Import Limitations**

When choosing your data migration path consider the following factors:

- The import options available to you
- The limitations of those import options
- Any workflow implications

For accessions data (e.g. for internal use and does not constitute a DACS-compliant collection description):

| Path: Access>>Excel>>AS Accessions CSV Template>>AS Accessions |
| Limitation: AS Accessions CSV allows import of only 1 agent and/or 1 subject per record. |
| Implication: If you have an accession with two creators, you may only import one creator using the agent field in the Accession CSV Template. If data includes multiple agents or subjects you want to retain, then do one of the following: |
| Link additional agents/subjects to accessions in AS after import Map additional agents/subjects to other field in AS Accessions CSV Template, such as Accession Content Description or Accession General Note. |
For collection level data (e.g. that is DACS-compliant or nearly so, but not in EAD):
Path: Access>>Excel>>AS Accessions CSV>>AS Accessions
Access>>Excel>>AS Accessions CSV>>AS Accessions>>spawn AS Resources
Limitation: AS Accessions CSV allows import of only 1 agent and/or 1 subject
AS Accessions CSV does not allow import of collection level notes, such as Abstract, Biographical/Historical, Preferred Citation, etc.
When spawning resource records from accessions, few fields stay in record
Implication: If data includes notes or multiple agents/subjects do one of the following:
Link additional agents/subjects to accessions in AS after import
Map additional agents/subjects to other field in AS Accessions CSV Template, such as Accession Content Description or Accession General Note.
Add collection notes after spawning resource records.
(or) Mailmerge to EAD .xml shell and import EAD to AS Resources

For item level data:
Path: In Access or Excel>>mailmerge to the Alliance’s EAD .xml shell>>AS Resources
Limitation: When using the Alliance’s EAD .xml shell to import item data the EAD .xml must be valid and include <eadheader>, <archdesc> data
Implication: You must encode EAD .xml mailmerge template with actual or placeholder <eadheader>, <archdesc> data
After importing EAD .xml shell with item data, you can merge with actual resource record for collection.

For names and subjects data:
Path: In Access or Excel>>mailmerge to EAD .xml>>AS Resources
Limitation: In AS deleting shell resource record will delete names/agents if they have not been linked to other records
Implication: You will have to retain shell resource record in AS if names/agents are not linked to other resource records.

Map Data and Scope Data Cleanup

After planning the migration path, map the data to the fields in the AS import tools or AS records.
Select a test batch of records that includes:
- a range of descriptive practice and data formats.
- at least 10 records, possibly more if data varies.
- some fully formed records, some less fully formed records
- some records with agents or subjects

Test import of the data as possible and track the data cleanup that is required or desired. Refer to documentation on AS Accessions, AS Resources, and AS Digital Objects, as necessary.

Test export of the data to ensure exported records comply with best practices and your expectations. For example, for collection data create a few example AS Resource records and then export EAD .xml finding aids, run them through the AS2AW script, and check for compliance with best practices using the Alliance tools.
Track all data cleanup required and document your data cleanup workflow. Then test workflow and data import and revise as necessary.

ArchivesSpace tools for importing data are:
- **AS Accessions CSV Template** and **CSV Map**
- **AS Resources EAD .xml Import / Export Map**
- **AS Resources MARC .xml Import / Export Map**
- **AS Digital Object CSV Template**, and **CSV Map**

The tools are linked here: [archivesspace.org/application/data-import-and-export-maps](https://archivesspace.org/application/data-import-and-export-maps)
And available on GitHub: [https://github.com/archivesspace/archivesspace](https://github.com/archivesspace/archivesspace)

Alliance tools for evaluating EAD .xml finding aids produced from resource records include:
- **EAD Encoding Template**
- **XML shell record**
- **AS2AW Conversion Tool** (on the [utility site](https://archivesspace.org/application/data-import-and-export-maps))
- **Validation Tool** (on the [utility site](https://archivesspace.org/application/data-import-and-export-maps))
- **Compliance Checker** (on the [utility site](https://archivesspace.org/application/data-import-and-export-maps))

**Mapping Accessions Data**

There are three ways to map accessions data.

**Option 1. Use the AS Accession CSV Map** ([CSV Map](https://github.com/archivesspace/archivesspace))
- The map notes the target fields in AS for each data and constraints on data for fields, including Field Length, Data Type, and Rules (Cols. D-F)
- Accession Date and Accession Number 1 are required fields.
- Add a column for:
  - your source data column;
  - your example data;
  - your data cleanup notes.
- Add your example data to the map and note:
  - the cleanup required to meet the rules
  - any cleanup desired but not required to meet the rules
  - any fields without data that you would like to supply on import

*Important Note: Avoid or minimize use of User Defined fields*
**AS Accession CSV Map with columns added for Source Data Column, Example Data, and Data Cleanup Notes**

**Option 2. Use the AS Accession CSV Template** ([AS Accessions CSV Template](#))

- The template includes placeholder data that indicates data type and data format for each field.
- Refer to the AS Accession CSV Map for constraints, such as Field Length, Data Type, and Rules.
- Do not change the order of columns or the column names.
- Accession Date (YYYY-MM-DD) and Accession Number are **required** fields.
- When adding Agents additional fields may be required: Primary Name, Rest of Name, Name Order, Source or Rules, Agent Role, Agent Type.
- When adding Subjects additional fields may be required: Subject Term Type, Subject Source.
- Delete the placeholder data.
- In Row 1, copy the header from each column of Access data to the appropriate column in Accessions CSV Template. (Do not alter the column headers in Accessions CSV Template.)
  - **Note:** Cells in template may be formatted. Select Ctrl+1 as necessary to reformat cells.
  - **Note:** Data in multiple columns of Access data may map to single column in template.
- In Row 2, copy example data from each column of Access data to appropriate column in the template.
  - If Access data includes data in multiple formats or types add examples to fully scope data cleanup
- In Row 3, enter notes on the data required or desired for or for those fields.
- Track data you have mapped to the template by shading columns in Access data spreadsheet
  - Use Green for those columns that map without cleanup
  - Use Yellow for those columns that map with cleanup
  - Use Red for columns that do not map (or) will not be migrated

**NOTES:**
- Do not change the values in the columns headers in the AS Accession CSV Template
- Do not change the order of the columns in the AS Accession CSV Template
- Accession Number and Accession Date are **required** fields
AS Accession CSV Template with rows for Access data column headers (Row 2), example data (Row 3), and data cleanup notes (Row 4).

Option 3. Create Records Manually in ArchivesSpace

- Select records from your Access data that exemplify the range of data in the database
- Enter records in ArchivesSpace and note data cleanup that is required or recommended

See the AS Usage Manual chapters on Resource Records and Accessions for guidance.

Mapping Collections and Item Data

There are two ways to map collections' data.

Option 1. Use the Alliance’s EAD Encoding Template

- Select records from your Access data that exemplify the range of data in the database
- Use the Alliance’s EAD Encoding Template to draft example EAD.xml finding aids for each. Refer to the Alliance’s EAD Best Practices to identify appropriate fields for data.
- Test against the Alliance’s Validation Tool and Compliance Checker.
- Test import to ArchivesSpace using the EAD import option.

Note:
• cleanup required to successfully import, validate, compliance check
• cleanup desired but not required to successfully import, validate, compliance check
• any fields without data that you would like to supply on import

Alliance EAD Encoding Template showing collection level elements.

Alliance EAD Encoding Template showing item level elements.

Option 2. Create Records in ArchivesSpace
• Select records from your Access data that exemplify the range of data in the database.
- Enter records in ArchivesSpace and note data cleanup that is required or desired.
- Export EAD .xml files and test with the Alliance’s Validation Tool and Compliance Checker.
- Note additional data cleanup that is required or desired.

After you map your data and scope the data cleanup, document your data cleanup workflow or procedure. Test the workflow and data import and revise as necessary if you encounter errors.

Now you have planned your migration! This is an essential step for a smooth process that meets the goals and will be well worth the time invested.

**Backup Data in Access**

Begin your preparations for migration by backing up your Access database. *Don’t skip this step; it will save you if you inadvertently insert an error during cleanup.*

1. Open the database you want to back up
2. Select File > Save As
3. Under File Types, select Save Database As.
4. Under Advanced, select Back Up Database and then select Save As.
5. If you like, change the backup file name.

**Cleanup Data**

You may edit your data at several points in the data migration path from Access to ArchivesSpace: by hand, by using find and replace and other tools to edit data in a spreadsheet, or by editing data after import to ArchivesSpace.

To use **OpenRefine** to edit data, see the documentation on [using OpenRefine for cleanup](#).

Common data cleanup activities include the following:

- Spell checking
- Controlling vocabulary lists
- Controlling variance in data values
- Formatting dates
- Supplying normal dates
- Supplying standard notes

**Notes on Editing Data in Excel**

- Save and work with data as a .csv file.
- Always copy columns within worksheets before editing data.
  - For example, if you are editing Column B
    - Insert an empty column after Column B
    - Copy and paste Column B to new column and name it “Column B Working”
    - Edit original Column B name to “Column B Original”
    - Complete edits in “Column B Working,” using “Column B Original” to compare edited values with original values as necessary.
    - After you complete edits in “Column B Working” change name to “Column B Final” and hide or delete “Column B Original”
● Note that Excel can prevent data from being edited by protecting worksheets and locking cells.
  ○ To unprotect worksheets, select:
    ■ File>Protect Workbook>Unprotect
    ■ (or) Review>Protect Sheet (or) Protect Workbook
  ○ To select Format Cells>Protection>uncheck “Locked”
● Note that Excel can auto-format data based on assumptions of data type, particularly when you are entering data, copying and pasting entire columns, or importing or exporting data.
  ○ Auto-format errors include: removing leading zeros and altering date formats
  ○ Minimize this by working with data as a .csv file
  ○ For more information on common issues of managing data in spreadsheets see AV
Preserve tutorial Managing Data in Spreadsheets.

Spellcheck Data
Excel includes a spell check tool. Archives Space does not, so this is a step to do pre-import.
To spellcheck data:
  ● select the column
  ● In the Review tab, select Spell Check
  ● Process spellcheck and save.

Controlled Vocabularies and Variant Data
There are a few ways to control vocabularies and variant data in Excel.

You can use the Filter tool to view and filter data in order to run find and replace operations to replace variants or non-preferred terms.

To filter In Excel:
  ● select Data tab then select Filter tool to enable filtering
  ● click on the menu arrow in the column header cell to launch Filter dialog box
  ● use the checkboxes to filter the list and then do find and replace operations to control data.

Or . . .
Copy and paste column to a new tab or spreadsheet.
Select column, choose Data>Remove Duplicates to display variants
Then run find and replace operations to control variants in original data tab.

Excel spreadsheet showing Remove Duplicates function to identify data variants.

Or . . .
Compile a controlled vocabulary in another tab in the same spreadsheet.
Select column in original data tab, choose Data>Data Validation
In Data Validation window, select Settings tab, and set Allow criteria to “list”
In Data Validation window, place cursor in Source field, select the tab with the controlled vocabulary, and highlight the range of cells containing the terms.
In Data Validation window, click Okay to apply validation rules.
In the original data tab, select the column then select Data>Validation>Circle invalid data. Variant terms will be circled and you can control terms by editing cells or running find and replace operations.

Formatting Dates

To format dates in Excel:
- Copy column to edit then sort data.
- Select cells or column to format and Ctrl+1 to format data in cells.
- Select appropriate format option from Date menu, or enter one in Custom.
  - For example, for accessions dates must be in format YYYY-MM-DD.
- Choose data category from Date or Custom and select or enter Type: YYYY-MM-DD
- If your accessions lack accession dates you will have to supply accession dates, since “accession_accession_date” is a required field.

Supplying Normal Dates
Supply normalized begin and end dates to facilitate search and retrieval in ArchivesSpace and other systems. Copy and edit date data to provide normalized dates, in YYYY format, to populate date_begin and date_end in Accessions CSV Template or EAD date normal attribute.

For more information on forming normalized dates, see the Library of Congress’ Extended Date Time format Level 0 documentation.

Supplying Standard Notes

To supply standard notes to accessions, resources, or digital objects add a column for the field, enter standard note text, and copy or fill cells with values.

For example, resource records require Access Restriction Notes in order to produce compliant EAD finding aids. To add the Access Restriction Note recommended by Archives West EAD Best Practices Guidelines for collections without restrictions (“Collection is open for research.”) add a column to the spreadsheet and copy the note text to all applicable rows.

Refer to user manual chapters on accessions, resources, or digital objects to identify recommended or required fields with data that is consistent across items and might be added to your spreadsheet.

Finalizing Data for Import

Once you have edited your data to your satisfaction, you are ready to finalize the data for import.

To do so in AS Accessions CSV Template or the AS Digital Objects CSV Template

- copy data to the template one column at a time
  - Insert a Column to the right of each column in the CSV template.
  - Copy and Paste the data column to the empty column
  - Copy and Paste the column header from the template to the newly filled column
  - Delete the empty column to the left
- or, replace the column headers in your spreadsheet with the column header in the template

To successfully import the data:

- file must be saved as .csv (comma separated value) format
- column headers and column order must exactly match those in import template
- data must comply with rules in AS Accessions CSV Map, e.g. Field Length, Data Type, Rules
- AS Accessions requires Identifier (accession_number_1) and Date (accession_accession_date), so each record must have metadata in these fields.
- When adding Agents and Subjects, additional related fields may be required

Backup Data

Before you import your data, make a copy of your data. Like the Access backup, this will serve you well if something goes wrong during the import process.

Import Data to ArchivesSpace
Import Process

In ArchivesSpace use the import functions to import data to ArchivesSpace.

For Accessions:
- In Create menu select Background Jobs
- Under New Background Job, select Job Type>Import Data
- Then select Import Type>Accession CSV
- Select Add File, then navigate to and select .csv file
- Select Queue Job

For Resources:
- In Create menu select Background Jobs
- Under New Background Job, select Job Type>Import Data
- Then select Import Type>EAD
- Select Add File, then navigate to and select .csv file
- Select Queue Job

For Digital Objects:
- In Create menu select Background Jobs
- Under New Background Job, select Job Type>Import Data
- Then select Import Type>Digital Object CSV
- Select Add File, then navigate to and select .csv file
- Select Queue Job

For additional information on using ArchivesSpace, see the resources in Archival Collection Management Documentation: https://www.orbiscascade.org/archival-collection-management-documentation

Common Migration Blocks and Fixes

Although addressing common errors before migration will take care of many issues, you may miss a few. These are errors you may encounter when importing accessions and digital objects. For errors importing resource data see ArchivesSpace Usage: Importing EAD.

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Problem</th>
<th>How to fix</th>
</tr>
</thead>
<tbody>
<tr>
<td>accession_date : Property is required but was missing</td>
<td>No date found for accession</td>
<td>Check mappings and correct date entry for accession_accession_date.</td>
</tr>
<tr>
<td>id_o : Property is required but was missing</td>
<td>Accession identifier missing.</td>
<td>Check mapping and add appropriate accession_number_1 value.</td>
</tr>
<tr>
<td>Not a valid date</td>
<td>Incorrect date format</td>
<td>See Formatting Dates to correct your date format</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
<td>Resolution</td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------------------------------------------------</td>
<td>-------------------------------------------------</td>
</tr>
<tr>
<td>title</td>
<td>Property is required but was missing</td>
<td>Missing title for digital object</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Check mappings and include a value for digital_object_title.</td>
</tr>
<tr>
<td>digital_object_id</td>
<td>Property is required but was missing</td>
<td>Digital object identifier missing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Check mapping and add appropriate digital_object_id value.</td>
</tr>
</tbody>
</table>